Welcome Guest [Log In] [Register]
Active Topics

Welcome to Kawasaki Owners Club. We hope you enjoy your visit.

We specialise in technical information & assistance for anyone seeking advice for all Kawasaki motorcycles.
To gain access to all Forums you will need to become a member.
This site is ad free to members.

Would new members please post a hello in Welcome to the forum before asking questions on the board


Join Kawasakiownersclub.com!


If you're already a member please log in to your account to access all of our features:

Username:   Password:
Add Reply
New member; Introduction
Topic Started: Jun 17 2017, 09:32 AM (142 Views)
Potter58
Newbie
[ * ]
Hi everyone, bought a Z1b a few months ago, been working on it since. Now on the road so I've just joined the group. Clutch was slipping but changing oil to mineral seems to have cured that. I have replaced all jets but it's running lean on 3 and rich on 4. Top end really strong but around 6000 rpm engine vibration stops me pushing. I would appreciate any input from your experiences. I have attached a picture. Phil
Offline Profile Quote Post Goto Top
 
Robert Harris
mach 3 500
[ *  *  *  *  *  *  *  * ]
:199 Good luck with the bike :444
Offline Profile Quote Post Goto Top
 
stigg
Member Avatar
Grand Master Poster
:999 :789
Offline Profile Quote Post Goto Top
 
Wizz
Member Avatar
Site Administrator

:199 :kawa
Offline Profile Quote Post Goto Top
 
1 user reading this topic (1 Guest and 0 Anonymous)
« Previous Topic · Welcome to the forum · Next Topic »
Add Reply





© KOC


Copyright © 1999-2017 All rights reserved www.kawasakiownersclub.com






eXTReMe Tracker